The issue impacting Amazon Punchouts in SunSupply has been resolved and all services are functioning as expected.
Please contact Concierge if you experience any issues. Thank you!
Posted Nov 25, 2025 - 14:27 EST
Update
Attention Team Members:
Until we can resolve the Amazon search issue in SunSupply, we have made the Amazon punchout available at the bottom of the page in the Additional Catalogs section. There is an Amazon Canada and Amazon US thumbnail in the bottom right section of the page.
Scroll down, click on the Amazon logo to shop Amazon and pull your carts back to SunSupply. We will continue to work with our vendor and towards a full resolution.
Thank you for your patience.
Posted Nov 25, 2025 - 09:57 EST
Investigating
Attention Team Members:
SunSupply is currently experiencing a partial outage. Amazon punchouts for both the US and Canada are unavailable. We have contacted our vendor and are working towards resolution.
We will send an update once service has been restored. We apologize for the inconvenience.