If you are experiencing an issue not reported here, please Contact Concierge.

Emergency Mass Communication (NetSuite) - Partial Outage

Incident Report for Sun Communities

Resolved

Attention Team Members,

The issue impacting Mass Communications in NetSuite has been resolved, and the functionality is now operating as expected.

If you experience any further issues, please contact Concierge for assistance.

Thank you!
Posted Jul 27, 2026 - 14:34 EDT

Investigating

Attention Team Members,

Emergency Communication in NetSuite is currently experiencing a partial outage affecting the delivery of mass communications sent to large groups of recipients.

Until a fix is implemented, please send communications to recipient groups of 30 or fewer whenever possible.

We will provide an update once service has been restored. We apologize for the inconvenience and appreciate your patience.
Posted Jul 08, 2026 - 11:02 EDT
This incident affected: NetSuite.